Recommended Posts

Well, as you may know, I have now installed Ubuntu onto my laptop computer. I have looked on the internet, and i found out that i need to use ndiswrapper to use my windows drivers on linux. I am not sure how to do it, and after following many different tutorials, nothing works. Anyone can help me (from square 1)?

EDIT: Sorry, forgot to mention (to those who don't know) that i want to use my linksys wireless-B PCMCIA card on Ubuntu. It has a realtek 8180l chipset. Thanks...

Link to post
Share on other sites

here is the linux driver for your card. (I belive its the same card, at least teh chipset you listed. )

then you need to learn the iwconfig command.

Link to post
Share on other sites
Thanks, I actually looked at the before but didn't know how to use it...If i transfer that file to Ubuntu, will I be able to decompress it properly?

Also, what iwconfig command would that be?



Support for the following wireless extension also exist:

iwconfig eth1 channel - (only in monitor/ad-hoc mode) sets the current channel

iwconfig eth1 mode XXXXX - switch between managed, ad-hoc and monitor mode

iwlist eth1 scan - (only in non-monitor mode) returns the list of the networks found by the nic

iwconfig eth1 essid - (only in managed mode) tries to associate with a BSS with the specified essid.

iwconfig eth1 essid - (only in ad-hoc mode) join/create an IBSS with the specified essid

iwconfig eth1 rate xxxxxxxx - sets the TX rate

ifconfig eth1 promisc - enable promisc mode in managed/ad-hoc mode

ifconfig eth1 -promisc - disables promisc mode in managed/ad-hoc mode

iwconfig eth1 frag - sets the tx fragmentation treshold

iwconfig eth1 key 1234.. - sets the WEP key for encryption/decryption

iwpriv eth1 badcrc X - X=1 or 0, if 1 frame with bad crc are accepted in monitor mode

iwconfig eth1 ap XX:XX:XX:XX:XX:XX - set the AP mac address in managed mode. Useful to associate with hidden essid BSS

iwconfig eth1 ap XX:XX:XX:XX:XX:XX - set the cell bssid in ad-hoc mode

iwpriv eth1 active scan X - X=1 or 0, if it NIC will perform active probe scanning, if 0 passive

iwpriv eth1 prismhdr X -X=1 or 0, in monitor mode set the header format to prism or regular 802.11

Where eth1 is your interface name (since v 0.7 the default is wlan0)

*Please note that the nic is sleeping until you run ifconfig up.*

as for uncomress it.. yes it will uncompress the file (you need to have your kernel headers installed under /usr/src/linux

to uncompress the comman tar -zxxvf <filename> will do..

then read the Install or Readme file in the archive for install instructions.

I don't have the card or I would run through it.

Link to post
Share on other sites

well, I have all the contents on my machine (basically a bunch of C files, a few other useful ones i don't know how to use in /home/murtaza). Whenever i type in cd /home/murtaza/rtl8180-0.21 (the folder), it works properly, and moves its directory. Then, when i type the command "make" it says a few things, among one saying that the target it not specified. How to I specify a target so when i compile the driver it'll actually work? This is getting really hard :lol:.

Link to post
Share on other sites

i just installed ubuntu on an old k6 laptop and i hav e dlink dwl-650 rev.m1 which uses the rtl8180 chip as well.

all i had to do to get it working was

1. install linux headers

sudo apt -get install build-essential linuxheaders-`uname -r`

2. then cd to the rtl8180 directory, make (the previuos package should be all you need to make the drivers, it was all i needed)

3. (assuming you have all the modules you pcmcia chipset needs)

type ./modules_load (scrtipt in rtl* directory) this will load the modules in the correct order

4. set the settings for network in /etc/network/interfaces:


auto lo

auto eth0

auto wlan0

iface lo inet loopback

iface eth0 inet dhcp

iface wlan0 inet dhcp #your device may be different, check iwconfig




wireless_essid linksys

wireless_mode managed

wireless_key **************************

wireless_channel 6

5. run:

/etc/init.d/pcmcia restart (may not be nessecary)

/etc/init.d/networking start

iwconfig wlan0 up

this worked to get my card working.

and thank you iccaros, ive had this card awhile hoping for an opensource driver

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.