Multiple Desktop Issue

Recommended Posts

I've seemed to develop a strange bug with KDE multiple desktops.


If I push my mouse to the top or the bottom of the screen, like trying to push it off the edge, it will switch desktops on me (it will happen on accident when closing a max'd window) first I thought it was just the apps minimizing themselves and it was really pi$$in' me off...Now that I know what's happening it's just a minor annoyance...being used to a single windows desktop, I seldom use multiple desktops so reducing it to 1 and removing the pager solves the problem but was wondering if someone else had seen this.

Link to post
Share on other sites

if you think its annoying now try it on dual monitors..

Link to post
Share on other sites
That's a feature.  Control Panels->Desktop->Window Behavior->Advanced->Active Desktop Borders.

you are the man!

I knew it had to be something stupid like that....I think I even went there looking for a setting to fix it but missed it....not sure why I just noticed this "feature"'s not like I don't spend waaaayyyy too many hours in front of this't see why someone would make a feature that would make you accidently change desktops this feature enabled by default?...I don't remember ever messing with it and I've only had this issue for a couple days....and I don't get liquored up around the

Thanks, jcl...much appreciated :)

Link to post
Share on other sites
can't see why someone would make a feature that would make you accidently change desktops though

Tradition. AFAIK it's more-or-less been the default behavior for window managers since the development of paged virtual desktops. It's simpler than switcher widgets, especially if you're trying to move windows between desktops. It also approximates the massive panning virtual desktops that were common in the old days.

Aside: Sketchpad, the first modern GUI (and arguably the first GUI, period) presented the user with a panning and zooming workspace that was approximately 1/3 square mile. On a machine with an ~800KIPS processor and ~288KiB of memory. Why we can't do that now is beyond me.

Is this feature enabled by default?

Don't think so.

Edited by jcl
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.