Win 10 machine restarts every (about) 30 minutes

Recommended Posts

About 2 weeks ago, my computer began restarting every 30 minutes. After a few days, the time between restarts varied between 30 minutes to 2 hours. I am concerned that it is my power supply, and unsure how to determine if that is the case. How can I determine what is causing this? Any ideas? Thanks!

Link to post
Share on other sites

Hey, have you ran a Power Supply check ?? or another here you can try this with no download :

Run a power efficiency diagnostics report of your PC in Windows 10.
You must be signed in as an administrator to be able to run a power efficiency diagnostics report.
For the best results, you should run the power efficiency diagnostics report when the PC is idle and with no open programs or documents.
1. Open an elevated command prompt.
2. In the elevated command prompt, copy and paste the command below, and press Enter.
CODE >>>  "powercfg -energy -output %USERPROFILE%\Desktop\Power_Efficiency_Diagnostics_Report.html" ...... without the quotation marks !! Also notice the spacing !!

3. Double click/tap on the Power_Efficiency_Diagnostics_Report.html file on your desktop to open and see the power efficiency diagnostics report in your default web browser (ex: Internet Explorer).

Hope this will help you determine if it's the Power Supply !!


Link to post
Share on other sites

Wow, that is a lot of info!

There are some references to USB drives not Entering Selective Suspend, the CPU Utilization Processor utilization is high, and Platform Power Management Capabilities:PCI Express Active State Power Management Disabled.


I don't understand what the third option means, but it does reference power. Do you understand what it means?

Link to post
Share on other sites

I fixed a computer last year with this solution so i hope it helps yours !! We removed the Power Management Capabilities !

1. Open an elevated command prompt.

2. Type the command below you want to use into the elevated command prompt, and press Enter.

(Add - default)
powercfg -attributes SUB_PCIEXPRESS ee12f906-d277-404b-b6da-e5fa1a576df5 -ATTRIB_HIDE


powercfg -attributes SUB_PCIEXPRESS ee12f906-d277-404b-b6da-e5fa1a576df5 +ATTRIB_HIDE

3. You can now close the elevated command prompt if you like.


If that doesn't work then the Only other thing i would do a  Windows10 Recovery !!


Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.