Standalone Box And Isa Proxy And Yum Update


Recommended Posts

With my box FC5 at work (Active Directory), I have been able to access the net , I have not logged in with my AD account , I logged in as username : root and password : forum,,,fake one (I know security implication, I have done this for test ).

First time when I tried to open a browser, window popped up asking me username and password for authentication to use internet (I entered my username: zillah and password:ad123 my active directory account,,,fake ), then I was able to browse the net.

When I tried to use the command below (via Terminal):

[[email protected]]#yum install yum (yumes),,,,It did not work, I believe because of the authentication (ISA proxy) that I mentioned above.

With the proxy , I followed the link below :

http://fedora.redhat.com/docs/yum/sn-yum-proxy-server.html

1- I added the line below to /etc/yum.conf

proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake username
proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake password

Then I tried to use this :

[root]#yum update yum,,,,,,,,,,,,,,,,,,I received this error :

Loading "installation" Plugin

Settingup Update Process

Setting up repositories

Can not find a valid baseurl for repo:case

Error: Cannot find valid baseurl for repo:core

2- I removed the configuration above and I tried these:

http_proxy=" http://zillah:[email protected]:8080 "
export http_proxy
yum update

[[email protected] # yum update yum

Traceback (most recent call last):

File "/usr/bin/yum", line 29, in ?

yummain.main(sys.argv[1:])

File "/usr/share/yum-cli/yummain.py", line 80, in main

base.getOptionsConfig(args)

File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig

self.doConfigSetup(fn=opts.conffil* e, root=root)

File "/usr/lib/python2.4/site-packages/* yum/__init__.py", line 102, in doConfigSetup

self.conf = config.readMainConfig(fn, root)

File "/usr/lib/python2.4/site-packages/* yum/config.py", line 567, in readMainConfig

confparser.read(configfile)

File "/usr/lib/python2.4/site-packages/* yum/parser.py", line 126, in read

ConfigParser.read(self,filename)

File "/usr/lib/python2.4/ConfigParser.p* y", line 267, in read

self._read(fp, filename)

File "/usr/lib/python2.4/ConfigParser.p* y", line 490, in _read

raise e

ConfigParser.ParsingError: File contains parsing errors: /etc/yum.conf

[line 15]: 'export http_proxy\n'

[line 16]: 'yum update\n'

Edited by zillah
Link to post
Share on other sites

first

this

http_proxy=" http://zillah:[email protected]:8080 "
export http_proxy
yum update

belongs in your .rc file for the user (/home/username/bash.rc)

your error from the first thing you changed is saying your repo list is bad (proxie not working could make this think it is bad), but Fedora 5 has fedora legacy links that do not exsist anymore , you may need to find an up to date repo list to fix this (or at least know that is not the problem)

FC 6 is out, you could get the list from that distro.

Link to post
Share on other sites
belongs in your .rc file for the user (/home/username/bash.rc)

Yes, you are right.

But the code below as link stated to be add to /etc/yum.conf,,,,did not work

proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake username
proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake password

Link to post
Share on other sites
belongs in your .rc file for the user (/home/username/bash.rc)

Yes, you are right.

But the code below as link stated to be add to /etc/yum.conf,,,,did not work

proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake username
proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,,,fake password

right? your first Error stated that it could not find the REPO, I am suggesting that its because the ones that come with FC5 are wrong.

try taking out the one listing legacy and see if that fixes it.

your second error is a parsing error of the scripts, so I think it does not like the shell settings.

Link to post
Share on other sites

should be no issue

Sorry, I can't be more help

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...